Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 04, 2025 - 12:00 UTC
Scheduled
Bluefin will be releasing a TecsClientRest software update to the Production on Wednesday, June 4th, 2025 from 14:00 pm to 15:00 pm CET. The software release to Production is not anticipated to impact service availability. If you experience any issues, please get in touch with our support staff for assistance.
Posted Jun 04, 2025 - 11:17 UTC
This scheduled maintenance affected: Transaction Processing.