Possible Interruption

Incident Report for Bluefin TECS Platform

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 01:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2026 - 00:35 UTC

Investigating

We are investigating a possible interruption in transaction processing. We appreciate your patience. Thank you.
Posted Jul 29, 2026 - 00:19 UTC
This incident affected: Transaction Processing.